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Intro to Unity 

Unity Overview 
Editor Interface 
Primitives 
Materials 
Textures 
Terrain 
Prefabs 
First Person Controller 
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What is Unity 

 
 
Unity is powerful, complete 3D environment 
 development system 
 
Create 3D objects / scenes / scripts in Unity 
Or import objects created in 3D modelling packages 
Use scripting to control animations / scene changes and 
interactivity 
Export to CAVE2 virtual reality environment 
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What is Unity 

Integrated development environment (IDE) 
Games and interactve 3D virtual environments development 
Commercial game engine (Free and Pro) 
Multi-platform 
Popular 
4.5 million registered users 
Large asset store (models, scripts) 
Support (formal and community) 
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What is Unity 

–  Game engine 
•  3D objects / lighting / physics / animation / scripting 

–  Accompanying script editor 
•  MonoDevelop (win/mac)  
•  Can also use Visual Studio (Windows) 

–  3D terrain editor 
–  3D object animation manager 
–  GUI system 
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Scripting 

MONO compiler 
Scripts can be written in 

JavaScript 
 Majority of introductory tutorials are written in Javascript 

 
C# 

Unity can be integrated with the Microsoft Visual Studio 
editor, to get full benefits of code completion, source version 
control, intergration, serious developers work in C# 
 

BOO (like Python) 
 Smaller development in this 
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Unity Games 
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Unity Games 

Angry Birds 
Deadlock 
The forest 
Dead trigger 
Deus Ex: The Fall 
Assassin’s Creed: Identity 
Satellite Reign 
Escape plan 
Wasteland 2 
and many more https://en.wikipedia.org/wiki/List_of_Unity_games 
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Institute for Creative Technologies /Skip Rizzo- Medical VR 
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Institute for Creative Technologies /Skip Rizzo- Medical VR 

Virtual	
  Reality	
  as	
  a	
  Tool	
  for	
  Delivering	
  PTSD	
  Exposure	
  Therapy	
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Free vs Pro 

Pro offers: 
 
Level of Detail 
No Personal Edition splash screen 
Profiler 
Full screen post processing effects (Oculus) 
Team License 
Unity Cloud Build Pro 
Unity Analytics Pro… 
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What is Unity 

Simplify development of games. 
  
Game Mechanics 

–  physics, AI 
Rendering Effects 

–  shadows, lighting 

I/O Abstraction 
–  input devices 

–  output devices 
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Multi Platform 

Multiple Build Targets 
•  Windows 
•  Linux 
•  iOS 
•  Android 
•  Web player 
•  Oculus Rift 
•  Wii 
•  … and more! 
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Other game engines 

 
Multiple Build Targets (Input/Output Abstraction) 
  
Windows 
Linux 
iOS 
Android 
Web 
… and more! 
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Other game engines 

 
Multiple Build Targets (Input/Output Abstraction) 
  
Windows 
Linux 
iOS 
Android 
Web 
… and more! 
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Editor 

1 – Scene            
–   Editable current scene with 3d 3D game objects where the 

game is constructed 
2 – Hierarchy 

 Text list of game objects and sub-objects in the current scene 
3 – Inspector 

 Properties for currently selected asset/object 
4 – Game 

 Preview how game will look when exectuting 
5 – Project 

 Contents of Project ‘assets’ folder (i.e. files in that folder) 
  library of scripts, digital media files, and scenes, library 
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Editor 

1 – Scene            
 Editable (design-time) 3D game objects in the current scene 

 
•  place for any visual assets in your Unity environment 
•  updates in real-time when you are previewing the game 
•  the manipulator on the top right allows you to switch between a 

number of standard views 
•  perspective view allows to view current scene with a vanishing 

point 
•     
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Editor 

2 – Hierarchy 
 Text list of game objects and sub-objects in the current scene 

 
•  lists all the objects in the currently loaded scene 
•  lists object children  
 
Children are objects that can be thought of as 
subordinate to the parent object; wherever the top object moves, 
they'll follow, keeping the current offset they have to this object.  
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Editor 

3 – Inspector 
 Properties for currently selected assets and objects  

•   
allows to look at and tweak individual settings of various game 
objects and assets 

•  allows to adjust global settings 
•  is content-sensitive  
•  changes its parameters based on which game object/asset is 

selected 
•  a place to show project settings and preferences by choosing 

them from the Edit menu 
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Editor 

4 – Game 
 Preview how game will look when exectuting 

 
•  previewing the game 
•  shows a rendering of how the game will look 
•  ignoring graphical effects that need to be computed at run-

time, from the point of view of the main camera 
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Editor 

Navigating the Scene Window 
 
 
 
 
The scene view is what allows you to look around and move the 
visual assets you import into Unity. It's how you'll assemble your levels 
and place important things like lighting, trigger zones, audio, and 
much more. Being able to control the camera is important if you 
want to do anything at all with it. 
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Hand Tool (shortcut Q) : drag around in the scene to pan your view. 
Holding down alt+drag will rotate the view, Ctrl.+drag will allow you to 
zoom. Does not move anything in the scene, just your point of view. 
 
Translate Tool (shortcut X) : active selection tool, enables to drag an 
object’s axis handles in order to reposition it. 
 
Rotate Tool (shortcut E) : using handles to allow you to rotate an object 
around either of its axes. 
 
Scale Tool (shortcut R) : works the same as the previous two tools, allows 
scaling of an object. 
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Primitives 

basic game objects Unity  
can create without  
Importing external assets 
•  lights 
•  particle systems 
•  cameras 
•  3D objects 
•  2D objects 
•  Etc. 
 
1. Game Object > 3D Object > Cube 
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Primitives 

 Scale: X: 25, Y: 1, Z: 25 
   
Move camera a little back  
and point it downward to see the box 
 
2. Game Object > 3D Object > Sphere 
Move and place it above the cube 
 
 Position: X: 0, Y: 2, Z: 0 
 Scale: X: 4, Y: 4, Z: 4 
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Primitives 

 Scale: X: 25, Y: 1, Z: 25 
   
Move camera a little back  
and point it downward to see the box 
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Primitives 

 Scale: X: 25, Y: 1, Z: 25 
   
Move camera a little back  
and point it downward to see the box 
    
3. Assign the sphere a rigid body component 
Select the sphere  
Component > Physics > Rigid Body 
 
4. Preview the game 
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Primitives 

 sphere should fall, but not bounce yet 
 
5. Create a physic material, which will provide the material 
properties to make the game object bouncy 
 
Asset > Create > Physics Material 
 
6. Drag the new physics material from the Asset window onto the 
Sphere game object in the Hierarchy window  
or directly onto the sphere in the Scene window 
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Primitives 

7. In inspector adjust the parameters  
 
Bounciness to 0.8 and  Bounce 
Combine to Maximum 
 
8. Preview the game 
the sphere should bounce similar to a rubber ball 
 
9. experiment with different heights and different angles  
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Materials 

10. Assets > Create > Material 
 
double click the color swatch next to Main color and choose a 
different color 
tweak the material’s properties by experimenting with different 
shaders from the shader drop-down menu in the Inspector window 
 
11. Drag new material from the Project window onto the game 
object in the Hierarchy window 
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Primitives 

 Scale: X: 25, Y: 1, Z: 25 
   
Move camera a little back  
and point it downward to see the box 
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Textures 

 
Textures should be in the following format to enable ‘tiling’ 

Square and the power of two 
 
128 x 128 
256 x 256 
512 x 512 
1024 x 1024 
 

Shaders control the rendering characteristics of textured surface 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

14. Change to top view  
-  the view manipulator icon in the Scene window’s top right corner 
(top-isometric) 
 
Zoom into the terrain (F key) 
 
15. Select Raise/Lower Terrain tool in the Inspector window  
(make sure the Terrain is selected in the Hierarchy window) 
“draw” on the top view of the ground plane in the Scene window 
to create terrain topography 
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Terrain 

16. Fine-tune brush size and opacity 
 
17. Maximize the scene window to see the details of your terrain 
 
18. Assets >  Import Package > Environment 
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Terrain 

16. Fine-tune brush size and opacity 
 
17. Maximize the scene window to see the details of your terrain 
 
18. Assets >  Import Package > Environment 
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Terrain 

 
Create terrain by selecting brush type, brush size and opacity  
Sculpt topology 
Set maximum height and smooth corners 
Textures loaded to paint texture onto terrain 
First texture acts as background, paint textures  
Paint on trees and grass.  
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Terrain 

 
19. Paint the terrain 
Select the Brush tool using Inspector window > Terrain 
 
20. Add Texture 
Add terrain texture  
Search for “sand” 
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Terrain 

16. Fine-tune brush size and opacity 
 
17. Maximize the scene window to see the details of your terrain 
 
18. Paint the terrain 
Select the Brush tool using Inspector window > Terrain 
 
19. Add Texture 
Add terrain texture  
Search for “sand” 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 



	
  	
  	
  	
  CS	
  491	
  /	
  DES	
  400	
  	
  	
  	
  Crea.ve	
  Coding	
  	
   Computer	
  Science	
  

Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Terrain 

 
Unity’s Terrain editor  
•  islands 
•  topographical landscapes 
•  Mountains 
•  And more 
 
 
12. Create a new Scene “terrain” and save it 
13. GameObject > 3D Object > Terrain 
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Prefabs 

pre-fabricated objects  
 
Prefabs store a game object together with its components 
(transforms, appearances, scripts, etc.) and configurations for easy 
duplication/reuse. 
 
Unity makes it easy to move around a world interactively (either in a 
first person or third person perspective) using prefabs. 
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Prefabs 

Object-oriented instances can be INSTANTIATED at run time 
 

At RUN TIME a script can cause a new object instance to be 
created (instantiated) at a given location / with a given transform 
set of properties 
 
Prefabs allow functional game objects to be reused in scenes 
(spawned) or imported into other projects as external assets. ‘The 
First Person Controller’ is an example of a Prefab 
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First Person Controller 

20. Assets >  Import Package > Characters 
 
Project Window > Standard Assets folder 
FPS Character > Prefabs > FPSController 
drag the FPS Controller onto your scene 
delete the main camera 
Preview the game 
 
explore the terrain  / look around with your mouse  
move with WASD or the arrow keys / jump with the space bar 



	
  	
  	
  	
  CS	
  491	
  /	
  DES	
  400	
  	
  	
  	
  Crea.ve	
  Coding	
  	
   Computer	
  Science	
  

First Person Controller 

20. Assets >  Import Package > Characters 
 
Project Window > Standard Assets folder 
FPS Character > Prefabs > FPSController 
drag the FPS Controller onto your scene 
delete the main camera 
Preview the game 
 
explore the terrain  / look around with your mouse  
move with WASD or the arrow keys / jump with the space bar 


